IX2015+HE.netで始めるIPv6トンネル接続

提供: 泣かないでゆり子
移動先: 案内検索
設置したIX2015。上にあるのはCisco1720、下にあるのはCatalyst2950。(どちらもIPv6非対応)

大学がIPv6プリフィックスを配ってくれないので、私設のCisco1721ルータで研究室からIPv6接続をしていたが、Cisco1721でPPPoE+IPoE接続をするために大学から自宅にCiscoルータを持って帰ってしまい、IPv6接続ができなくなってしまったので、別に新しく買ったNEC Univerge IX2015を研究室に設置してIPv6接続をしてみた(^^♪

5Mbpsくらいしか出ないCiscoルータと比べて、82.16Mbpsも出るw ちなみにv4の実効速度は455Mbpsほど。

コンフィグの説明

各ポートの設定など、基本的なことはIX2005でPPPoE+IPoE接続に書いてあるので、そっちを参照。IPv6トンネリングまわりの説明だけ書く・・・

設置環境は大学の研究室で、v4アドレスがDHCPによって配られる。研究室のアドレス空間は150.43.***.32/27、DHCP払い出し範囲は150.43.***.42~61なので、150.43.***.~41までのアドレス空間は固定割当に使える。IX2015のv4アドレスはこの空間の固定v4アドレスを設定する。IPv6のアドレス配布、ルーティングは、まだ全学で行われていない(なので私設トンネルを作る)。

FE0/0に固定v4アドレスを割当し、トンネル接続を確立。RAをLAN内に流し、各PCにv6アドレスを配布。v6 DNSアドレスはRAの Other-config-flag を立ててDHCPv6によって配布。

各PCから流れてきたv6パケットはFE0/0からルータに入り、v4パケットにカプセル化されて再びFE0/0を通り、トンネル終点までv4網をルーティングされる。戻りは逆ルートとなる。

6over4トンネル

Tunnel0をIPv6のデフォルトルートに
ipv6 route default Tunnel0.0
トンネルを掘る
interface Tunnel0.0
 description Hurricane Electric IPv6 Broker
 tunnel mode 6-over-4
 tunnel destination 74.82.46.6 //トンネル終点アドレス(v4)
 tunnel source 150.43.***.36 //トンネル起点アドレス(v4) FE0/0のv4アドレス
 no ip address
 ipv6 enable
 ipv6 address 2001:470:23:a17::2/64 //トンネル起点アドレス(v6)
 no shutdown

物理I/F設定

interface FastEthernet0/0.0
 description LocalLAN
 ip address 150.43.***.36/27 //v4アドレス
 ipv6 enable
 ipv6 address 2001:470:24:a17::1/64 //v6アドレス (IPoEと違って無設定にはできない)
 ipv6 address fe80::1/64 //管理のしやすいリンクローカルアドレスを付ける。(dead:beef:cafe:babeとかでもおk www)
 no shutdown

DHCPv6

IPv6 DNS情報を配る
ipv6 dhcp enable
ipv6 dhcp server-profile dhcpv6
 dns-server 2001:4860:4860::8888 //Google Public DNS
 dns-server 2001:4860:4860::8844 //配りたいv6 DNSアドレスをココに。プロバイダがv6 DNSをサービスしてれば、それを使ってもいい。
interface FastEthernet0/0.0
 ipv6 dhcp server dhcpv6
 ipv6 nd other-config-flag //RAの Other-config-flagを立てて、v6 DNSアドレスをDHCPv6から取得させる。
RA送信
interface FastEthernet0/0.0
 ipv6 nd send-ra

ISDN

ISDN交換機タイプをINS64に (いらないw)
device BRI1/0
 isdn switch-type ins64 //←いらないw

コンフィグ

Current configuration : 2620 bytes

! NEC Portable Internetwork Core Operating System Software
! IX Series IX2010 (magellan-sec) Software, Version 7.3.27, RELEASE SOFTWARE
! Compiled Apr 27-Thu-2006 14:03:32 JST #2
! Current time Oct 27-Tue-2015 12:22:02 JST
!
service password-encryption
!
hostname IX2015
timezone +09 00
!
!
username admin password hash ******************** administrator
!
!
!
!
ntp server 150.43.1.5
ntp server 133.243.238.163
ntp server 2001:df0:232:eea0::fff3
!
!
!
logging buffered 1048576
logging subsystem all error
logging timestamp timeofday
!
!
!
ip route default 150.43.***.62
ip dhcp enable
ip access-list telnet permit ip src 150.43.***.32/27 dest 150.43.***.36/32
ip access-list telnet permit ip src 10.0.0.0/30 dest any
!
!
ipv6 route default Tunnel0.0
ipv6 dhcp enable
ipv6 access-list telnet6 permit ip src 2001:470:24:a17::0/64 dest 2001:470:24:a1
7::1
ipv6 access-list telnet6 permit ip src fe80::0/10 dest fe80::1
ipv6 access-list telnet6 permit ip src 240b:252:8a0:100::0/64 dest any
!
!
!
!
ip name-server 150.43.1.3
ip name-server 8.8.8.8
ipv6 name-server 2001:4860:4860::8888
ipv6 name-server 2001:4860:4860::8844
!
!
telnet-server ip enable
telnet-server ip access-list telnet
telnet-server ipv6 enable
telnet-server ipv6 access-list telnet6
!
!
!
!
!
!
!
!
ip dhcp profile configure
  assignable-range 10.0.0.2 10.0.0.2
  subnet-mask 255.255.255.252
  default-gateway 10.0.0.1
  dns-server 10.0.0.1 8.8.8.8
  domain-name config.yuriko.local
!
ipv6 dhcp server-profile dhcpv6
  dns-server 2001:4860:4860::8888
  dns-server 2001:4860:4860::8844
!
device FastEthernet0/0
!
device FastEthernet0/1
!
device FastEthernet1/0
!
device BRI1/0
  isdn switch-type ins64
!
interface FastEthernet0/0.0
  description LocalLAN
  ip address 150.43.***.36/27
  ipv6 enable
  ipv6 address 2001:470:24:a17::1/64
  ipv6 address fe80::1/64
  ipv6 dhcp server dhcpv6
  ipv6 nd send-ra
  ipv6 nd other-config-flag
  no shutdown
!
interface FastEthernet0/1.0
  description ConfigurePort
  ip address 10.0.0.1/30
  ip dhcp binding configure
  no shutdown
!
interface FastEthernet1/0.0
  no ip address
  shutdown
!
interface BRI1/0.0
  encapsulation ppp
  no auto-connect
  no ip address
  shutdown
!
interface Loopback0.0
  no ip address
!
interface Null0.0
  no ip address
!
interface Tunnel0.0
  description Hurricane Electric IPv6 Broker
  tunnel mode 6-over-4
  tunnel destination 74.82.46.6
  tunnel source 150.43.***.36
  no ip address
  ipv6 enable
  ipv6 address 2001:470:23:a17::2/64
  no shutdown

関連項目

Cisco1721+HE.netで始めるIPv6トンネル接続 - Ciscoルータを使う場合のコンフィグ

参考サイト