IX2005でPPPoE+IPoE接続

提供: 泣かないでゆり子
移動先: 案内検索
電子レンジ上に設置したIX2005とGE-PON。

高速VPNアクセスルータ NEC Univerge IX2005 が手に入ったので、低速なCisco1721から乗り換えてみた(^^♪ 高速というだけあって、v4もv6もほぼ100Mbps出るぅ~。(Cisco1721は最大8Mbpsぐらいしか出ない・・・) 人気のIX2015と違って、IX2005はPPP、VPN、BAKランプが付いてる。特にPPPランプが付いてるのは便利♪ そのかわりFastEthernetが一つ少なくて、BRIポートも無い(今時BRIイラネ・・・)。筐体の大きさはIX2015の半分くらい。コンパクトでGood!

コンフィグの説明

IPアドレス等は、各自自分の環境に読み替えること。

//はコメント

大まかな説明としてはBiglobeへPPPoE接続してIPv4インターネットへ接続。LAN内からのv4パケットはNAPTされてWAN側へ出ていく。LAN内へはDHCPで192.168.24.0/24のアドレスを配布。IPv6パススルーによって、WAN側からのIPv6 RAをLAN内にそのまま流してLAN内のPCにIPv6アドレスを割り当て。ルータにもv6アドレスを割り当てることによって、v6網からルータの管理ができるようにする。アクセスリストによってTelnet、httpアクセスできるアドレス範囲を制限。特に公開サーバ等はないので、DMZやポート開放等は行っていない。

FE0をWAN側として、GE-PONを直結。FE1の各ポートをLAN側(VLAN1)として、PCやWiFiブリッジなどをぶら下げ。

IPv6

IPv6パススルー (IPoE)
access-list ipv6path permit src any dest any type ipv6
access-list ipv6path permit src any dest any type ip
bridge irb enable //Integrated Routing and Bridging
no bridge 1 bridge ip //IPv4はWAN側へブリッジングせずにルーティング+NAPTする
//FE0とFE1をブリッジグループ1に追加
interface FastEthernet0.0
 description WAN
 filter ipv6path 1 in
 bridge-group 1
 no shutdown
interface FastEthernet1.0
 description LocalLAN
 filter ipv6path 1 in
 no ipv6 nd import-prefix
 bridge-group 1
 no shutdown
デフォルトルートをIPoEに (JPNE系v6網の場合「PREFIX::fffe」にするとインターネットへルーティングされる模様) ルータにv6グローバルアドレスを振らない場合は設定しなくてもいい。
ipv6 route default 240b:252:8a0:100::fffe
ルータにIPv6アドレス割当 (割り当てなくてもLAN内のPCはIPv6網にアクセスできる)
interface BVI1
 no ip address
 ipv6 enable
 ipv6 address 240b:252:8a0:100::1/64
 ipv6 address fe80::1/10
 bridge-group 1
 no shutdown
Telnetアクセス(IPv6)
ipv6 access-list telnet6 permit ip src 2001:470:24:a17::0/64 dest any
ipv6 access-list telnet6 permit ip src 240b:252:8a0:100::0/64 dest any
ipv6 access-list telnet6 permit ip src fe80::0/10 dest any
telnet-server ipv6 enable
telnet-server ipv6 access-list telnet6

IPv4

デフォルトルートをPPPoEに
ip route default FastEthernet0.1
LAN向けDHCP
ip dhcp enable
ip dhcp profile lan
 assignable-range 192.168.24.2 192.168.24.50
 default-gateway 192.168.24.1
 dns-server 192.168.24.1 8.8.8.8
 domain-name yuriko.local //無くてもいいw
interface FastEthernet1.0
 ip dhcp binding lan
DNSサーバ(IX2005をLAN内向けDNSとして稼働させる)
ip name-server 8.8.8.8 //Google Public DNS
ip name-server 8.8.4.4 //プロバイダのDNSでもいい
dns cache enable
dns cache max-records 256
proxy-dns ip enable
proxy-dns ip max-sessions 128
proxy-dns ip query-interval 1
PPPoE (Biglobe)
ppp profile biglobe
 authentication myname ********@biglobe.ne.jp
 authentication secret-password 1 ********@biglobe.ne.jp ************************
interface FastEthernet0.1
 description PPPoE
 encapsulation pppoe
 auto-connect
 ppp binding biglobe
 ip address ipcp //WAN側IPアドレス自動取得
 ip mtu 1454
 ip tcp adjust-mss auto
 no shutdown
NAPT
interface FastEthernet0.1
 ip napt enable
LAN側IPv4アドレス設定
interface FastEthernet1.0
 ip address 192.168.24.1/24
Telnet、httpアクセス
username admin password hash ********** administrator //Telnetユーザ名とパスワード
telnet-server ip enable
telnet-server ip access-list telnet
ip access-list telnet permit ip src 157.7.234.135/32 dest any //所有ConoHa VPSからのアクセス許可
ip access-list telnet permit ip src 192.168.24.0/24 dest any //LAN内からのアクセス許可
http-server username admin
http-server ip access-list telnet
http-server ip enable

その他

show running-config中のパスワード難読可
service password-encryption
ホスト名
hostname IX2005
タイムゾーン(JST)
timezone +09 00
NTPまわり
ntp server 150.43.1.5 //(fitntp.fit.ac.jp)
ntp server 2001:df0:232:eea0::fff3 //(NICTv6)
ntp server 133.243.238.164 //(NICT)
ntp retry 3
ntp interval 3600
ログまわり
logging buffered 1048576
logging subsystem all error
logging timestamp datetime
???
ip ufs-cache enable

コンフィグ

Current configuration : 2811 bytes

! NEC Portable Internetwork Core Operating System Software
! IX Series IX2005 (magellan-sec) Software, Version 7.5.59, RELEASE SOFTWARE
! Compiled Feb 13-Tue-2007 13:26:31 JST #2
! Current time Oct 26-Mon-2015 01:33:05 JST
!
service password-encryption
!
hostname IX2005
timezone +09 00
!
!
username admin password hash ********** administrator
!
!
!
ntp server 150.43.1.5
ntp server 2001:df0:232:eea0::fff3
ntp server 133.243.238.164
ntp retry 3
ntp interval 3600
!
!
!
logging buffered 1048576
logging subsystem all error
logging timestamp datetime
!
access-list ipv6path permit src any dest any type ipv6
access-list ipv6path permit src any dest any type ip
!
!
ip route default FastEthernet0.1
ip dhcp enable
ip access-list telnet permit ip src 157.7.234.135/32 dest any
ip access-list telnet permit ip src 192.168.24.0/24 dest any
ip ufs-cache enable
!
!
ipv6 route default 240b:252:8a0:100::fffe
ipv6 access-list telnet6 permit ip src 2001:470:24:a17::0/64 dest any
ipv6 access-list telnet6 permit ip src 240b:252:8a0:100::0/64 dest any
ipv6 access-list telnet6 permit ip src fe80::0/10 dest any
!
!
!
bridge irb enable
no bridge 1 bridge ip
!
!
ip name-server 8.8.8.8
ip name-server 8.8.4.4
dns cache enable
dns cache max-records 256
!
proxy-dns ip enable
proxy-dns ip max-sessions 128
proxy-dns ip query-interval 1
!
telnet-server ip enable
telnet-server ip access-list telnet
telnet-server ipv6 enable
telnet-server ipv6 access-list telnet6
!
http-server username admin
http-server ip access-list telnet
http-server ip enable
!
!
!
!
!
ppp profile biglobe
  authentication myname ********@biglobe.ne.jp
  authentication secret-password 1 ********@biglobe.ne.jp ************************
!
ip dhcp profile lan
  assignable-range 192.168.24.2 192.168.24.50
  default-gateway 192.168.24.1
  dns-server 192.168.24.1 8.8.8.8
  domain-name yuriko.local
!
device FastEthernet0
!
device FastEthernet1
!
interface FastEthernet0.0
  description WAN
  filter ipv6path 1 in
  no ip address
  bridge-group 1
  no shutdown
!
interface FastEthernet1.0
  description LocalLAN
  filter ipv6path 1 in
  ip address 192.168.24.1/24
  ip dhcp binding lan
  no ipv6 nd import-prefix
  bridge-group 1
  no shutdown
!
interface FastEthernet0.1
  description PPPoE
  encapsulation pppoe
  auto-connect
  ppp binding biglobe
  ip address ipcp
  ip mtu 1454
  ip tcp adjust-mss auto
  ip napt enable
  no shutdown
!
interface FastEthernet1.1
  encapsulation pppoe
  auto-connect
  no ip address
  shutdown
!
interface BVI1
  no ip address
  ipv6 enable
  ipv6 address 240b:252:8a0:100::1/64
  ipv6 address fe80::1/64
  bridge-group 1
  no shutdown
!
interface Loopback0.0
  no ip address
!
interface Null0.0
  no ip address