Cisco1721でPPPoE+IPoE接続

提供: 泣かないでゆり子
移動先: 案内検索
電子レンジ上に設置したCisco1721とGE-PON、WiFiブリッジ。

2013年からずっとWiMAX回線を使っていたが2015年9月、自宅にようやく光回線がやってきたのでCisco1721ルータでIPv6接続してみた(^^♪ (ブロードバンドルータを買うお金がなかったので、大学研究室でIPv6トンネリングに使っていたCiscoルータを流用したw) WiFiは契約の切れたWiMAXルータをWiFiブリッジとして使ってます。

プロバイダはBiglobe。回線はNTT西のフレッツ光ネクスト隼。

IPv4はPPPoEによる接続。ルータからDHCPでクラスCプライベートアドレスを配布。

IPv6はIPoEによる接続。IPv6パケットをルータでルーティングせずWAN側にブリッジし(IPv6パススルー)、上流からのRAがLAN内まで流れてくるようにする。

Ciscoルータのファームウェア・バージョンは、12.4(10) (C1700-SY7-M)。物理インタフェースはfa0、Vlan1(fa1~4 WIC-4ESW)。fa0がWAN側で、GE-PONを直結。Vlan1がLAN側で、WiFiブリッジなどがぶら下がっている。

※2015年10月 IX2005が手に入ったので乗り換えました。Cisco1721はノロかった・・・

コンフィグの説明

気が向いたら書く…

コンフィグ

Current configuration : 2760 bytes
!
! Last configuration change at 15:57:41 JST Thu Oct 8 2015
! NVRAM config last updated at 15:57:54 JST Thu Oct 8 2015
!
version 12.4
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
service password-encryption
!
hostname C1721
!
boot-start-marker
boot system flash c1700-sy7-mz.124-10.bin
boot-end-marker
!
enable secret 5 ******************************
!
no aaa new-model
clock timezone JST 9
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.24.1
!
ip dhcp pool DHCP
   network 192.168.24.0 255.255.255.0
   dns-server 8.8.8.8 8.8.4.4
   default-router 192.168.24.1
!
!
ip cef
ip domain name yuriko.local
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ipv6 unicast-routing
!
!
bridge irb
!
!
interface FastEthernet0
 description WAN
 no ip address
 ip virtual-reassembly
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
 no cdp enable
 bridge-group 1
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface Vlan1
 description LocalLAN
 no ip address
 ip virtual-reassembly
 bridge-group 1
 bridge-group 1 input-type-list 200
!
interface Dialer1
 description PPPoE
 mtu 1454
 ip address negotiated
 ip access-group DENY-INBOUND-TCP-SYN in
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip tcp adjust-mss 1414
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname ********@biglobe.ne.jp
 ppp chap password 7 ******************
 ppp ipcp dns request
!
interface BVI1
 description IPv6 Path trough bridge
 ip address 192.168.24.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1414
 ipv6 enable
!
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
ip nat inside source list 1 interface Dialer1 overload
!
!
!
ip access-list extended DENY-INBOUND-TCP-SYN
 permit tcp any any established
 permit tcp host 157.7.234.135 any eq telnet
 permit icmp any any
 permit udp any any
access-list 1 permit 192.168.24.0 0.0.0.255
access-list 200 permit 0x86DD 0x0000
access-list 200 permit 0x0800 0x0000
access-list 200 permit 0x0806 0x0000
dialer-list 1 protocol ip permit
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
 logging synchronous
line aux 0
 password 7 ************************
 login
 transport input telnet
line vty 0 4
 exec-timeout 120 0
 password 7 ************************
 logging synchronous
 login
 exec prompt timestamp
line vty 5 15
 exec-timeout 120 0
 password 7 ************************
 logging synchronous
 login
!
ntp clock-period 17179922
ntp server 150.43.1.5
ntp server 133.243.238.243
end

参考サイト